import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<iframe[^<>]*\\bdata-context\\b[^<>]*>[\\s\\S]*?<\\/iframe>";
final String string = "<iframe src=\"http://youtube.com\"></iframe> \n\n"
+ "<iframe data-context=\"whatever\" src=\"http://youtube.com\"></iframe> \n\n"
+ "<iframe src=\"http://youtube.com\"></iframe> <iframe src=\"http://youtube.com\"></iframe> \n\n"
+ "<p>Potatoes are good</p>\n\n"
+ "<iframe src=\"http://youtube.com\"></iframe> \n\n"
+ "<iframe src=\"http://youtube.com\" data-context=\"whatever\"></iframe>\n\n"
+ "<iframe src=\"http://youtube.com\"></iframe> \n\n"
+ "<iframe src=\"http://instagram.com\"></iframe> ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}