const regex = /<iframe[^<>]*\bdata-context\b[^<>]*>[\s\S]*?<\/iframe>/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<iframe[^<>]*\\bdata-context\\b[^<>]*>[\\s\\S]*?<\\\/iframe>', 'ig')
const str = `<iframe src="http://youtube.com"></iframe>
<iframe data-context="whatever" src="http://youtube.com"></iframe>
<iframe src="http://youtube.com"></iframe> <iframe src="http://youtube.com"></iframe>
<p>Potatoes are good</p>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://youtube.com" data-context="whatever"></iframe>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://instagram.com"></iframe> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}