package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<iframe[^<>]*\bdata-context\b[^<>]*>[\s\S]*?<\/iframe>`)
var str = `<iframe src="http://youtube.com"></iframe>
<iframe data-context="whatever" src="http://youtube.com"></iframe>
<iframe src="http://youtube.com"></iframe> <iframe src="http://youtube.com"></iframe>
<p>Potatoes are good</p>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://youtube.com" data-context="whatever"></iframe>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://instagram.com"></iframe> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}