// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<iframe[^<>]*\bdata-context\b[^<>]*>[\s\S]*?<\/iframe>").unwrap();
let string = "<iframe src=\"http://youtube.com\"></iframe>
<iframe data-context=\"whatever\" src=\"http://youtube.com\"></iframe>
<iframe src=\"http://youtube.com\"></iframe> <iframe src=\"http://youtube.com\"></iframe>
<p>Potatoes are good</p>
<iframe src=\"http://youtube.com\"></iframe>
<iframe src=\"http://youtube.com\" data-context=\"whatever\"></iframe>
<iframe src=\"http://youtube.com\"></iframe>
<iframe src=\"http://instagram.com\"></iframe> ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}