import re
regex = re.compile(r"<iframe[^<>]*\bdata-context\b[^<>]*>[\s\S]*?<\/iframe>", flags=re.IGNORECASE)
test_str = ("<iframe src=\"http://youtube.com\"></iframe> \n\n"
"<iframe data-context=\"whatever\" src=\"http://youtube.com\"></iframe> \n\n"
"<iframe src=\"http://youtube.com\"></iframe> <iframe src=\"http://youtube.com\"></iframe> \n\n"
"<p>Potatoes are good</p>\n\n"
"<iframe src=\"http://youtube.com\"></iframe> \n\n"
"<iframe src=\"http://youtube.com\" data-context=\"whatever\"></iframe>\n\n"
"<iframe src=\"http://youtube.com\"></iframe> \n\n"
"<iframe src=\"http://instagram.com\"></iframe> ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")