package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^"]*"|(very)`)
var str = `Fred Smith, very loudly said yesterday at a press conference that very fresh peas will "very, very defintely not" be served at the upcoming county fair`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}