re = /"[^"]*"|(very)/
str = 'Fred Smith, very loudly said yesterday at a press conference that very fresh peas will "very, very defintely not" be served at the upcoming county fair'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end