const regex = /"[^"]*"|(very)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"]*"|(very)', 'g')
const str = `Fred Smith, very loudly said yesterday at a press conference that very fresh peas will "very, very defintely not" be served at the upcoming county fair`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}