#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/www\.reddit\.com\/r\/.+"
Local $sString = "https://www.reddit.com/r/userscripts/comments/u3avus/greasemonkey_regex_for_matching_only/" & @CRLF & _
"" & @CRLF & _
"https://www.reddit.com/r/ForzaHorizon/new/" & @CRLF & _
"" & @CRLF & _
"https://www.reddit.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")