const regex = /https:\/\/www\.reddit\.com\/r\/.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/www\\.reddit\\.com\\\/r\\\/.+', 'gm')
const str = `https://www.reddit.com/r/userscripts/comments/u3avus/greasemonkey_regex_for_matching_only/
https://www.reddit.com/r/ForzaHorizon/new/
https://www.reddit.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}