using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/www\.reddit\.com\/r\/.+";
string input = @"https://www.reddit.com/r/userscripts/comments/u3avus/greasemonkey_regex_for_matching_only/
https://www.reddit.com/r/ForzaHorizon/new/
https://www.reddit.com/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}