$re = '/https:\/\/www\.reddit\.com\/r\/.+/m';
$str = 'https://www.reddit.com/r/userscripts/comments/u3avus/greasemonkey_regex_for_matching_only/
https://www.reddit.com/r/ForzaHorizon/new/
https://www.reddit.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);