import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/www\\.reddit\\.com\\/r\\/.+";
final String string = "https://www.reddit.com/r/userscripts/comments/u3avus/greasemonkey_regex_for_matching_only/\n\n"
+ "https://www.reddit.com/r/ForzaHorizon/new/\n\n"
+ "https://www.reddit.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}