#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<form[^>]*name="loginForm"[^>]*>[^~]*?<\/form>"
Local $sString = "<html>" & @CRLF & _
"<body>" & @CRLF & _
"<form method = "post" name="loginForm" >" & @CRLF & _
"<input type="text" name="firstName"/>" & @CRLF & _
"<input type="text" name="lastName"/>" & @CRLF & _
"</form>" & @CRLF & _
"<form method = "post" name="signupForm" >" & @CRLF & _
"<input type="text" name="userName"/>" & @CRLF & _
"</form>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")