$re = '/<form[^>]*name="loginForm"[^>]*>[^~]*?<\/form>/m';
$str = '<html>
<body>
<form method = "post" name="loginForm" >
<input type="text" name="firstName"/>
<input type="text" name="lastName"/>
</form>
<form method = "post" name="signupForm" >
<input type="text" name="userName"/>
</form>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);