import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<form[^>]*name=\"loginForm\"[^>]*>[^~]*?<\\/form>";
final String string = "<html>\n"
+ "<body>\n"
+ "<form method = \"post\" name=\"loginForm\" >\n"
+ "<input type=\"text\" name=\"firstName\"/>\n"
+ "<input type=\"text\" name=\"lastName\"/>\n"
+ "</form>\n"
+ "<form method = \"post\" name=\"signupForm\" >\n"
+ "<input type=\"text\" name=\"userName\"/>\n"
+ "</form>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}