re = /<form[^>]*name="loginForm"[^>]*>[^~]*?<\/form>/m
str = '<html>
<body>
<form method = "post" name="loginForm" >
<input type="text" name="firstName"/>
<input type="text" name="lastName"/>
</form>
<form method = "post" name="signupForm" >
<input type="text" name="userName"/>
</form>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end