using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""externalLinks\""[\s\S]+?(?=\""maxPop\"")";
string input = @"""oge"": ""GOF"",
""original"": {
""report"": true,
""tier"": ""IA""
},
""pertinentNegative"": false,
""populationFrequency"": {
""externalLinks"": {
""7-2-A-T"": ""https://x.d.org/s/7-d-A-T?dataset=s""
},
""maxPop"": ""South Asian"",
""maxPopAC"": 1,
""maxPopAN"": 30,
""maxPopFreq"": 3.276,
""overallPopAC"": 1,
""overallPopAN"": 23,
""overallPopFreq"": 4.22,
""source"": ""gnomAD""
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}