import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"externalLinks\\\"[\\s\\S]+?(?=\\\"maxPop\\\")";
final String string = "\"oge\": \"GOF\",\n"
+ " \"original\": {\n"
+ " \"report\": true,\n"
+ " \"tier\": \"IA\"\n"
+ " },\n"
+ " \"pertinentNegative\": false,\n"
+ " \"populationFrequency\": {\n"
+ " \"externalLinks\": {\n"
+ " \"7-2-A-T\": \"https://x.d.org/s/7-d-A-T?dataset=s\"\n"
+ " },\n"
+ " \"maxPop\": \"South Asian\",\n"
+ " \"maxPopAC\": 1,\n"
+ " \"maxPopAN\": 30,\n"
+ " \"maxPopFreq\": 3.276,\n"
+ " \"overallPopAC\": 1,\n"
+ " \"overallPopAN\": 23,\n"
+ " \"overallPopFreq\": 4.22,\n"
+ " \"source\": \"gnomAD\"\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}