import Foundation
let pattern = #"\"externalLinks\"[\s\S]+?(?=\"maxPop\")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"oge": "GOF",
"original": {
"report": true,
"tier": "IA"
},
"pertinentNegative": false,
"populationFrequency": {
"externalLinks": {
"7-2-A-T": "https://x.d.org/s/7-d-A-T?dataset=s"
},
"maxPop": "South Asian",
"maxPopAC": 1,
"maxPopAN": 30,
"maxPopFreq": 3.276,
"overallPopAC": 1,
"overallPopAN": 23,
"overallPopFreq": 4.22,
"source": "gnomAD"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)