$re = '/\"externalLinks\"[\s\S]+?(?=\"maxPop\")/m';
$str = '"oge": "GOF",
"original": {
"report": true,
"tier": "IA"
},
"pertinentNegative": false,
"populationFrequency": {
"externalLinks": {
"7-2-A-T": "https://x.d.org/s/7-d-A-T?dataset=s"
},
"maxPop": "South Asian",
"maxPopAC": 1,
"maxPopAN": 30,
"maxPopFreq": 3.276,
"overallPopAC": 1,
"overallPopAN": 23,
"overallPopFreq": 4.22,
"source": "gnomAD"
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);