const regex = new RegExp('\\"externalLinks\\"[\\s\\S]+?(?=\\"maxPop\\")', 'gm')
const str = `"oge": "GOF",
"original": {
"report": true,
"tier": "IA"
},
"pertinentNegative": false,
"populationFrequency": {
"externalLinks": {
"7-2-A-T": "https://x.d.org/s/7-d-A-T?dataset=s"
},
"maxPop": "South Asian",
"maxPopAC": 1,
"maxPopAN": 30,
"maxPopFreq": 3.276,
"overallPopAC": 1,
"overallPopAN": 23,
"overallPopFreq": 4.22,
"source": "gnomAD"
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}