import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ZZ=.*\\r?\\n.*\\r?\\nXXX.*(?:\\r?\\n.+)*(?:\\r?\\n){2}.*(.*)";
final String string = "ZZ=101\n"
+ "OO\n"
+ "XXX\n"
+ "111111111111\n"
+ "222222222222\n\n\n"
+ "AAAAAAAAAAAA\n\n"
+ "AAAAAAAAAAAA\n\n"
+ "OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}