re = /^ZZ=.*\r?\n.*\r?\nXXX.*(?:\r?\n.+)*(?:\r?\n){2}.*(.*)/m
str = 'ZZ=101
OO
XXX
111111111111
222222222222
AAAAAAAAAAAA
AAAAAAAAAAAA
OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end