import re
regex = re.compile(r"^ZZ=.*\r?\n.*\r?\nXXX.*(?:\r?\n.+)*(?:\r?\n){2}.*(.*)", flags=re.MULTILINE)
test_str = ("ZZ=101\n"
"OO\n"
"XXX\n"
"111111111111\n"
"222222222222\n\n\n"
"AAAAAAAAAAAA\n\n"
"AAAAAAAAAAAA\n\n"
"OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")