$re = '/^ZZ=.*\r?\n.*\r?\nXXX.*(?:\r?\n.+)*(?:\r?\n){2}.*(.*)/m';
$str = 'ZZ=101
OO
XXX
111111111111
222222222222
AAAAAAAAAAAA
AAAAAAAAAAAA
OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);