// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^ZZ=.*\r?\n.*\r?\nXXX.*(?:\r?\n.+)*(?:\r?\n){2}.*(.*)").unwrap();
let string = "ZZ=101
OO
XXX
111111111111
222222222222
AAAAAAAAAAAA
AAAAAAAAAAAA
OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}