use strict;
my $str = 'ZZ=101
OO
XXX
111111111111
222222222222
AAAAAAAAAAAA
AAAAAAAAAAAA
OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO
';
my $regex = qr/^ZZ=.*\r?\n.*\r?\nXXX.*(?:\r?\n.+)*(?:\r?\n){2}.*(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}