#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!isn't )(?<!not )\b(?:good|great)\b"
Local $sString = "good words" & @CRLF & _
"not good words" & @CRLF & _
"isn't good words" & @CRLF & _
"great words" & @CRLF & _
"not great words" & @CRLF & _
"isn't great words" & @CRLF & _
"words good" & @CRLF & _
"words not good" & @CRLF & _
"words isn't good" & @CRLF & _
"words great" & @CRLF & _
"words not great" & @CRLF & _
"words isn't great" & @CRLF & _
"words good words" & @CRLF & _
"words not good words" & @CRLF & _
"words isn't good words" & @CRLF & _
"words great words" & @CRLF & _
"words not great words" & @CRLF & _
"words isn't great words"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")