# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!isn't )(?<!not )\b(?:good|great)\b"
test_str = ("good words\n"
"not good words\n"
"isn't good words\n"
"great words\n"
"not great words\n"
"isn't great words\n"
"words good\n"
"words not good\n"
"words isn't good\n"
"words great\n"
"words not great\n"
"words isn't great\n"
"words good words\n"
"words not good words\n"
"words isn't good words\n"
"words great words\n"
"words not great words\n"
"words isn't great words")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.