import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!isn't )(?<!not )\\b(?:good|great)\\b";
final String string = "good words\n"
+ "not good words\n"
+ "isn't good words\n"
+ "great words\n"
+ "not great words\n"
+ "isn't great words\n"
+ "words good\n"
+ "words not good\n"
+ "words isn't good\n"
+ "words great\n"
+ "words not great\n"
+ "words isn't great\n"
+ "words good words\n"
+ "words not good words\n"
+ "words isn't good words\n"
+ "words great words\n"
+ "words not great words\n"
+ "words isn't great words";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}