use strict;
my $str = 'good words
not good words
isn\'t good words
great words
not great words
isn\'t great words
words good
words not good
words isn\'t good
words great
words not great
words isn\'t great
words good words
words not good words
words isn\'t good words
words great words
words not great words
words isn\'t great words';
my $regex = qr/(?<!isn't )(?<!not )\b(?:good|great)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}