re = /(?<!isn't )(?<!not )\b(?:good|great)\b/m
str = 'good words
not good words
isn\'t good words
great words
not great words
isn\'t great words
words good
words not good
words isn\'t good
words great
words not great
words isn\'t great
words good words
words not good words
words isn\'t good words
words great words
words not great words
words isn\'t great words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end