using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!isn't )(?<!not )\b(?:good|great)\b";
string input = @"good words
not good words
isn't good words
great words
not great words
isn't great words
words good
words not good
words isn't good
words great
words not great
words isn't great
words good words
words not good words
words isn't good words
words great words
words not great words
words isn't great words";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}