#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*(aa|bb|cc){1}.*(aa|bb|cc){1}.*(aa|bb|cc){1}.*"
Local $sString = "Ala ma 2 koty oraz 4 psy i coś jeszcze" & @CRLF & _
"Ala maaa 2 kotycc oraz 4 psy ibb coś jeszcze" & @CRLF & _
"Ala ma 2 koty cc oraz 4 psy aa i coś jeszcze bb" & @CRLF & _
"Ala ma 2 kotycc orazbb 4 psy i cośaa jeszcze" & @CRLF & _
"Ala ma 2 kotydd orazbb 4 psy i cośaa jeszcze" & @CRLF & _
"Ala ma 2 koty aaoraz 4 psyaa ibb cośbb jeszczecccc" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")