import Foundation
let pattern = #".*(aa|bb|cc){1}.*(aa|bb|cc){1}.*(aa|bb|cc){1}.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ala ma 2 koty oraz 4 psy i coś jeszcze
Ala maaa 2 kotycc oraz 4 psy ibb coś jeszcze
Ala ma 2 koty cc oraz 4 psy aa i coś jeszcze bb
Ala ma 2 kotycc orazbb 4 psy i cośaa jeszcze
Ala ma 2 kotydd orazbb 4 psy i cośaa jeszcze
Ala ma 2 koty aaoraz 4 psyaa ibb cośbb jeszczecccc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)