# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*(aa|bb|cc){1}.*(aa|bb|cc){1}.*(aa|bb|cc){1}.*"
test_str = ("Ala ma 2 koty oraz 4 psy i coś jeszcze\n"
"Ala maaa 2 kotycc oraz 4 psy ibb coś jeszcze\n"
"Ala ma 2 koty cc oraz 4 psy aa i coś jeszcze bb\n"
"Ala ma 2 kotycc orazbb 4 psy i cośaa jeszcze\n"
"Ala ma 2 kotydd orazbb 4 psy i cośaa jeszcze\n"
"Ala ma 2 koty aaoraz 4 psyaa ibb cośbb jeszczecccc\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.