using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(aa|bb|cc){1}.*(aa|bb|cc){1}.*(aa|bb|cc){1}.*";
string input = @"Ala ma 2 koty oraz 4 psy i coś jeszcze
Ala maaa 2 kotycc oraz 4 psy ibb coś jeszcze
Ala ma 2 koty cc oraz 4 psy aa i coś jeszcze bb
Ala ma 2 kotycc orazbb 4 psy i cośaa jeszcze
Ala ma 2 kotydd orazbb 4 psy i cośaa jeszcze
Ala ma 2 koty aaoraz 4 psyaa ibb cośbb jeszczecccc
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}