import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(aa|bb|cc){1}.*(aa|bb|cc){1}.*(aa|bb|cc){1}.*";
final String string = "Ala ma 2 koty oraz 4 psy i coś jeszcze\n"
+ "Ala maaa 2 kotycc oraz 4 psy ibb coś jeszcze\n"
+ "Ala ma 2 koty cc oraz 4 psy aa i coś jeszcze bb\n"
+ "Ala ma 2 kotycc orazbb 4 psy i cośaa jeszcze\n"
+ "Ala ma 2 kotydd orazbb 4 psy i cośaa jeszcze\n"
+ "Ala ma 2 koty aaoraz 4 psyaa ibb cośbb jeszczecccc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}