package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(aa|bb|cc){1}.*(aa|bb|cc){1}.*(aa|bb|cc){1}.*`)
var str = `Ala ma 2 koty oraz 4 psy i coś jeszcze
Ala maaa 2 kotycc oraz 4 psy ibb coś jeszcze
Ala ma 2 koty cc oraz 4 psy aa i coś jeszcze bb
Ala ma 2 kotycc orazbb 4 psy i cośaa jeszcze
Ala ma 2 kotydd orazbb 4 psy i cośaa jeszcze
Ala ma 2 koty aaoraz 4 psyaa ibb cośbb jeszczecccc
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}