#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\0098|98|0)?09\d{9}$"
Local $sString = "09923656565" & @CRLF & _
"09194183232" & @CRLF & _
"09456565985" & @CRLF & _
"09196183232" & @CRLF & _
"09121234567" & @CRLF & _
"" & @CRLF & _
"// not match" & @CRLF & _
"+989196185544" & @CRLF & _
"00989121234567" & @CRLF & _
"+9809121234567" & @CRLF & _
"9121234567" & @CRLF & _
"989121234567" & @CRLF & _
"+18087339090" & @CRLF & _
"+918087339090" & @CRLF & _
"+9128087339090" & @CRLF & _
"8087339090" & @CRLF & _
"08087339090" & @CRLF & _
"+1-8087339090 " & @CRLF & _
"+91-8087339090" & @CRLF & _
"+912-8087339090"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")