// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\0098|98|0)?09\d{9}$").unwrap();
let string = "09923656565
09194183232
09456565985
09196183232
09121234567
// not match
+989196185544
00989121234567
+9809121234567
9121234567
989121234567
+18087339090
+918087339090
+9128087339090
8087339090
08087339090
+1-8087339090
+91-8087339090
+912-8087339090";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}