import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\0098|98|0)?09\\d{9}$";
final String string = "09923656565\n"
+ "09194183232\n"
+ "09456565985\n"
+ "09196183232\n"
+ "09121234567\n\n"
+ "// not match\n"
+ "+989196185544\n"
+ "00989121234567\n"
+ "+9809121234567\n"
+ "9121234567\n"
+ "989121234567\n"
+ "+18087339090\n"
+ "+918087339090\n"
+ "+9128087339090\n"
+ "8087339090\n"
+ "08087339090\n"
+ "+1-8087339090 \n"
+ "+91-8087339090\n"
+ "+912-8087339090";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}