package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\0098|98|0)?09\d{9}$`)
var str = `09923656565
09194183232
09456565985
09196183232
09121234567
// not match
+989196185544
00989121234567
+9809121234567
9121234567
989121234567
+18087339090
+918087339090
+9128087339090
8087339090
08087339090
+1-8087339090
+91-8087339090
+912-8087339090`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}