use strict;
my $str = '09923656565
09194183232
09456565985
09196183232
09121234567
// not match
+989196185544
00989121234567
+9809121234567
9121234567
989121234567
+18087339090
+918087339090
+9128087339090
8087339090
08087339090
+1-8087339090
+91-8087339090
+912-8087339090';
my $regex = qr/^(\0098|98|0)?09\d{9}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}