# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\0098|98|0)?09\d{9}$"
test_str = ("09923656565\n"
"09194183232\n"
"09456565985\n"
"09196183232\n"
"09121234567\n\n"
"// not match\n"
"+989196185544\n"
"00989121234567\n"
"+9809121234567\n"
"9121234567\n"
"989121234567\n"
"+18087339090\n"
"+918087339090\n"
"+9128087339090\n"
"8087339090\n"
"08087339090\n"
"+1-8087339090 \n"
"+91-8087339090\n"
"+912-8087339090")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.