# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?=\.|$)|[^0-9.\n]//gm;t' <<< "1...2.3.
1.2.3...
.....
1.1.1.1
1.441.13443.134434"