using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?=\.|$)|[^0-9.\n]";
string substitution = @"";
string input = @"1...2.3.
1.2.3...
.....
1.1.1.1
1.441.13443.134434";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}