#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.(?=\.|$)|[^0-9.\n]"
Local $sString = "1...2.3." & @CRLF & _
"1.2.3..." & @CRLF & _
"....." & @CRLF & _
"1.1.1.1" & @CRLF & _
"1.441.13443.134434"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)