import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(?=\\.|$)|[^0-9.\\n]";
final String string = "1...2.3.\n"
+ "1.2.3...\n"
+ ".....\n"
+ "1.1.1.1\n"
+ "1.441.13443.134434";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}